根据eclipse的提示,把其中的错误清除干净即可!

解决方案 »

  1. 看看有没有用到1.6支持,2.2不支持的库,函数等。按照eclipse的提示换掉即可。
      

  2. android2.2的模拟器怎么建立呢?
      

  3. Android模拟器安装教程以及Android2.2模拟实测
    http://bbs.shouji.com.cn/do/viewthread?thread=321439
    有图有真相
      

  4. 这个网址被禁止 我打不开 可不可以贴过来,还有我怎么安装android2.2版本的库呢
      

  5. 在eclipse中,右击项目 -> Properties -> Android -> 勾选Android 2.2 -> Apply -> OK。
    然后稍等一下,build一下项目,再针对error解决问题。
    通常高版本的都会兼容低版本的。Android建立模拟器的方法都是一样的,它们是通过Target来标识不同版本的模拟器。
    如:
    建立android1.6的模拟器,Target要选择 Android 1.6 - API Level 4
    建立android2.2的模拟器,Target要选择 Android 2.2 - API Level 7
      

  6. 好像我的android2.2没安装?里面没有啊 只有1.5和1.6
      

  7. 安装android2.2版本的库
    可以自动更新,也可以下载下来装给你个安详介绍,我就只安装这个搭建的
    Android_2.2_开发环境配置详解.doc
    http://download.csdn.net/source/2608106
      

  8. 主要就是版本SDK兼容的问题 。不兼容的做相应修改就可以了 。
      

  9. 那为什么android2.2模拟器出错呢,没办法进入主菜单
      

  10. 看看这几点,上下logcat就行了Android 2.2兼容性移植
      

类似问题 »